JTool segfaults on disassembling TaiG

Used for discussing the various tools in the book as well as encouraging members to share tools

JTool segfaults on disassembling TaiG

Postby Siguza » Sat Feb 06, 2016 10:29 pm

I just tried to disassemble the TaiG untether binary for 8.4 with JTool 0.98.99999, and got a segfault.
The exact command I ran was: jtool -d -arch arm64 taig
The -v and -vv flags only produce one additional line of output, which I believe does not matter here:
Library dependency blob at offset 21ca8

That is all information I have.
For anyone else reading this, the untether binary can be downloaded from here and extracted with ar -x *.deb and subsequently tar -xf data.tar.gz.
User avatar
Siguza
Unicorn
 
Posts: 158
Joined: Thu Jan 28, 2016 10:38 am

Re: JTool segfaults on disassembling TaiG

Postby morpheus » Sat Feb 06, 2016 11:59 pm

Oops. Never fixed that. You can work around with NOOBJC=1 which would work fine, or by thinning binary first.
Incidentally, I supplied the binaries in my writeup about TaiG II , along with the DMG and other files.
morpheus
Site Admin
 
Posts: 532
Joined: Thu Apr 11, 2013 6:24 pm


Return to Tools

Who is online

Users browsing this forum: No registered users and 3 guests