jtool linux error

Used for discussing the various tools in the book as well as encouraging members to share tools

jtool linux error

Postby helloipa » Mon Nov 07, 2016 10:10 am

Hi,

I have some errors with Jtool.
What are the required dependencies?
I believe I should be able to run a make linux32 to install it on a simple ubuntu vm right?

When I try to run jtool.ELF32, the command is not recognized.
When i try to run jtool.ELF64 against DamnVulnerable.ipa file, I receive this error message: Unable to recognize this file - 4034B50

any idea?
Thanks.

Best regards,
helloipa
 
Posts: 2
Joined: Mon Nov 07, 2016 10:04 am

Re: jtool linux error

Postby morpheus » Mon Nov 07, 2016 1:19 pm

You're running it on an iPA. You should run it on the actual app itself (that is, the Mach-O inside the ipa, following extraction). And you don't need to make anything - it's already built (no sources)
morpheus
Site Admin
 
Posts: 532
Joined: Thu Apr 11, 2013 6:24 pm

Re: jtool linux error

Postby helloipa » Tue Nov 08, 2016 3:47 am

I managed to run jtool following your guidances. Thanks.
helloipa
 
Posts: 2
Joined: Mon Nov 07, 2016 10:04 am


Return to Tools

Who is online

Users browsing this forum: No registered users and 1 guest