Page 1 of 1

jtool linux error

PostPosted: Mon Nov 07, 2016 10:10 am
by helloipa
Hi,

I have some errors with Jtool.
What are the required dependencies?
I believe I should be able to run a make linux32 to install it on a simple ubuntu vm right?

When I try to run jtool.ELF32, the command is not recognized.
When i try to run jtool.ELF64 against DamnVulnerable.ipa file, I receive this error message: Unable to recognize this file - 4034B50

any idea?
Thanks.

Best regards,

Re: jtool linux error

PostPosted: Mon Nov 07, 2016 1:19 pm
by morpheus
You're running it on an iPA. You should run it on the actual app itself (that is, the Mach-O inside the ipa, following extraction). And you don't need to make anything - it's already built (no sources)

Re: jtool linux error

PostPosted: Tue Nov 08, 2016 3:47 am
by helloipa
I managed to run jtool following your guidances. Thanks.