ls issue from iosbinpack

Used for discussing the various tools in the book as well as encouraging members to share tools

ls issue from iosbinpack

Postby matteyeux » Sun Mar 27, 2016 11:18 am

Hey there !
I've some issues with ls bin from iosbinpack.
Code: Select all
P105AP:~ root# ls /
ls: illegal option -- -
usage: ls [-ABCFGHLOPRSTUWabcdefghiklmnopqrstuwx1] [file ...]
P105AP:~ root#


It prints the same output with all ls commands. I don't have this issue when I run /bin/ls
matteyeux
 
Posts: 15
Joined: Tue Jan 05, 2016 7:59 pm

Re: ls issue from iosbinpack

Postby morpheus » Sun Mar 27, 2016 1:06 pm

Unalias your ls! It's carrying an alias from Cydia which uses an old and non-darwin switch.

You can also use \ls
or /bin/ls

instead of ls.
morpheus
Site Admin
 
Posts: 532
Joined: Thu Apr 11, 2013 6:24 pm

Re: ls issue from iosbinpack

Postby matteyeux » Sun Mar 27, 2016 1:47 pm

I unaliased ls, it worked thanks.
matteyeux
 
Posts: 15
Joined: Tue Jan 05, 2016 7:59 pm

Re: ls issue from iosbinpack

Postby matteyeux » Sun Mar 27, 2016 2:47 pm

I have another issue with zsh :
Code: Select all
zsh: failed to load module `zsh/zle': dlopen(/usr/local/lib/zsh/5.0.8/zsh/zle.so, 9): no suitable image found.  Did find:\n\t/usr/local/lib/zsh/5.0.8/zsh/zle.so: malformed mach-o image: segment load command __LINKEDIT filesize is larger than vmsize


It seems like I'm not the only one with this issue
matteyeux
 
Posts: 15
Joined: Tue Jan 05, 2016 7:59 pm

Re: ls issue from iosbinpack

Postby morpheus » Mon Mar 28, 2016 6:27 pm

It's a minor issue - zsh still works. One of the libraries was improperly compiled for 32 (works well on 64).

But I'm on vacation. Talk next week.
morpheus
Site Admin
 
Posts: 532
Joined: Thu Apr 11, 2013 6:24 pm


Return to Tools

Who is online

Users browsing this forum: No registered users and 3 guests